Wikipedia:CSVloader

Bách khoa toàn thư mở Wikipedia
Bước tới: menu, tìm kiếm

CSVLoader là một công cụ hỗ trợ trong chương trình WP:AWB, nó giúp các thành viên có thể tạo ra các bài hàng loạt một cách nhanh chóng theo chế độ bán tự động hoặc tự động nếu có tài khoản bot. Các bước tiến hành theo thứ tự như sau:

Tạo file có phần mở rộng csv hoặc txt[sửa | sửa mã nguồn]

Trước tiên cần tạo một file có phần mở rộng là *.csv hoặc *.txt. Cột đầu tiên của file này phải là tên bài mà bạn cần muốn tạo. Ở đây chúng ta nên sử dụng định dạng txt sẽ có nhiều thuận lợi hơn như lưu tập tin ở dạng Unicode (UTF-8), nên những phần sau của bài viết sẽ đề cập đến file có phần mở rộng là txt.

Bạn không nên tạo dòng tiêu đề của từ cột trong file txt, việc này sẽ được thực hiện sau khi thiết lập các thông số của của csv loader.

Ví dụ, ta có danh sách các đô thị của bang Acre, Brasil như sau:

Comune Microregione Mesoregione Area (km²) Popolazione Densità
Acrelândia Rio Branco Vale do Acre 1.574,55 11.451 7,27
Assis Brasil Brasiléia Vale do Acre 2876 5063 1,76
Brasiléia Brasiléia Vale do Acre 4.336 18.377 4,20
Bujari Rio Branco Vale do Acre 3.468 7.019 1,91
Capixaba Rio Branco Vale do Acre 1.713 6.096 3,56
Cruzeiro do Sul Cruzeiro do Sul Vale do Juruá 7.925 86.725 10,94
Epitaciolândia Brasiléia Vale do Acre 1.659 13.344 7,32

Hãy tạo ra một file txt có nội dung như sau:

Acrelândia; Rio Branco;Vale do Acre;1.574,55;11.451;7,27
Assis Brasil;Brasiléia;Vale do Acre;2876;5063;1,76
Brasiléia;Brasiléia;Vale do Acre;4.336;18.377;4,20

Giữa các trường là dấu ; (chấm phẩy), nếu sử dụng dấu , (phẩy) có thể chương trình sẽ nhầm lẫn dấu phẩy trong con số với dấu phẩy mặc định của CSV loader.

Cài thêm [csv plugin][sửa | sửa mã nguồn]

Chép file CSVLoader.dll đã tải xuống vào thư mục chứa AutoWikiBrowser (kế file AutoWikiBrowser.exe). File này sẽ tự động hiển thị trong danh mục 'Plugins khi đã khởi động AWB.


Mở [csv plugin][sửa | sửa mã nguồn]

WPCSV 1.JPG

Khởi động AutoWikiBrowser và đăng nhập vào tài khoảng của bạn

WPCSV 4.JPG

Chọn [CSV Loader plugin] từ [Plugins menu]

WPCSV 2.JPG

Bạn sẽ được dẫn đến hộp hướng dẫn mở một file. Chọn file txt mà bạn đã tạo và click Open.

Chọn [plugin settings][sửa | sửa mã nguồn]

WPCSV 5.JPG

Cửa sổ [CSV Loader Settings] hiện ra. Hãy điền tên các cột vào [column headers] và nội dung bài viết trong hộp [text].

Trong cửa sổ [csv loader settings],

  1. schọn hoặc bỏ qua nếu không có sửa đổi cần thực hiện [no changes] (mặc định là bỏ qua)
  2. trong mục [Seperated by] nhập vào dấu ; (chấm phẩy) là dấu phân cách giữa các cột như đề cập ở trên
  3. nhập vào tiêu đề các cột (các tiêu đề này phải nằm giữ 4 dấu thăng như ##XX##), ví dụ:
    ##city##,##district##,##state##,##country##. Danh sách bài viết sẽ không hiển thị nếu dòng [Column Headers] bị bỏ trống.
  4. chọn các thức biên tập/tạo bài [append] (thêm nội dung vào cuối bài viết), prepend (thêm nội dung vào đầu bài viết) hoặc [replace] thay thế bằng đoạn văn bản mới.
  5. nhập vào nội dung bài viết (sử dụng các tiêu đề thay thế như đã khai báo trong phần [column headers] trong từng đoạn thích hợp, ví dụ: ##city## là một thành phố trong [[quận ##district##]] thuộc bang [[##state##]], [[##country##]]). Đối với các bản mẫu thì không cần thiết phải thêm các kí tự kí tự ##, ví dụ: {{city}}
  6. click OK


WPCSV 3.JPG

Danh sách các bài viết sẽ hiển thị trong ô ở góc dưới bên trái chương trình AWB.

Khai báo các thông số cuối cùng và chạy chương trình[sửa | sửa mã nguồn]

WPCSV 6.JPG

Trên màn hình chính, chọn thẻ [Skip].

Ở tận cùng bên dưới chọn vào ô Exists (chương trình sẽ bỏ qua các bài viết đã tồn tại) và chỉ tạo các bài mới.

WPCSV 7.JPG

Click vào thẻ [Start].

Gõ thông điệp cần hiển thị trong [edit summary].

WPCSV 8.JPG

Click [Start], bài viết đầu tiên trong danh sách của file txt sẽ hiển thị trên cửa sổ bên trên.

WPCSV 9.JPG

Click [Save] để lưu bài viết

WPCSV 10.JPG

Tương tự chương trình sẽ hiển thị bài viết tiếp theo, và click [Save].

WPCSV 11.JPG

Làm tương tự cho đến khi thực hiện tất cả các bài viết.

WPCSV 12.JPG

Để lưu lại cài đặt lúc làm việc [loader settings], chọn menu [Save Settings As] từ menu [File]

WPCSV 13.JPG

Nhập vào tên file và click [Save] để đóng hộp thoại.

WPCSV 14.JPG

Đối với các thao tác thay thế, click [Normal Settings] trên thẻ [Options], nhớ thực hiện thao tác này trước khi nhấn vào nút [Start]

WPCSV 15.JPG

Add the corrections to the list. Make sure to uncheck the add replacements to edit summaries box

Xem thêm[sửa | sửa mã nguồn]